# fastmcp (PyPI) vulnerabilities

8 known vulnerabilities (1 critical, 2 high, 5 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 4.1.6 (Nov 3, 2026): no advisory affects it
- Newest unaffected release: 4.1.6 (Nov 3, 2026), the latest release
- Weekly downloads: 13.1M
- Releases: 142 since 0.1.0 (Nov 30, 2024)
- Registry: https://pypi.org/project/fastmcp/
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- GHSA-7XGJ-8392-5Q4R: 3.0.0 to 3.4.9 (3.4.10 is outside it); 4.0.0 to 4.1.1 (4.1.2 is outside it)
- GHSA-VQQP-X5QM-5QP4: 4.0.0a1 to 4.1.1 (4.1.2 is outside it)
- CVE-2026-27124: 0.1.0 to 3.1.1 (3.2.0 is outside it)
- CVE-2025-64340: 0.1.0 to 3.1.1 (3.2.0 is outside it)
- CVE-2026-32871: 0.1.0 to 3.1.1 (3.2.0 is outside it)
- CVE-2025-69196: 0.1.0 to 2.14.1 (2.14.2 is outside it)
- CVE-2025-62801: 0.1.0 to 2.13.0rc3 (2.13.0 is outside it)
- CVE-2025-62800: 0.1.0 to 2.13.0rc3 (2.13.0 is outside it)

## Advisories (8)

### [GHSA-7XGJ-8392-5Q4R](https://cve.now/GHSA-7XGJ-8392-5Q4R): FastMCP: Post-transform component authorization is skipped on direct calls

- Severity: Medium
- Published: Oct 23, 2026
- Affected: from 3.0.0, fixed in 3.4.10; from 4.0.0, fixed in 4.1.2.
- Fixed in 3.4.10 (released Oct 20, 2026, 3 days before disclosure) and 4.1.2 (released Oct 20, 2026, 3 days before disclosure).
- The latest release, 4.1.6, is not affected.

### [GHSA-VQQP-X5QM-5QP4](https://cve.now/GHSA-VQQP-X5QM-5QP4): FastMCP MCP client wrappers construct M2M OAuth providers without issuer binding — client secret redirectable to attacker-advertised authori

- Severity: Medium
- Published: Oct 23, 2026
- Affected: from 4.0.0a1, fixed in 4.1.2.
- Fixed in 4.1.2 (released Oct 20, 2026, 3 days before disclosure).
- The latest release, 4.1.6, is not affected.

### [CVE-2026-27124](https://cve.now/CVE-2026-27124): FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities

- Severity: High 8.2
- Published: Apr 3, 2026
- Affected: fixed in 3.2.0.
- Fixed in 3.2.0 (released Mar 30, 2026, 4 days before disclosure).
- The latest release, 4.1.6, is not affected.

### [CVE-2025-64340](https://cve.now/CVE-2025-64340): FastMCP has a Command Injection vulnerability - Gemini CLI

- Severity: Medium 6.7
- Published: Apr 3, 2026
- Affected: fixed in 3.2.0.
- Fixed in 3.2.0 (released Mar 30, 2026, 4 days before disclosure).
- The latest release, 4.1.6, is not affected.

### [CVE-2026-32871](https://cve.now/CVE-2026-32871): FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability

- Severity: Critical 10.0
- Published: Apr 2, 2026
- Affected: fixed in 3.2.0.
- Fixed in 3.2.0 (released Mar 30, 2026, 3 days before disclosure).
- The latest release, 4.1.6, is not affected.

### [CVE-2025-69196](https://cve.now/CVE-2025-69196): FastMCP OAuth Proxy token reuse across MCP servers

- Severity: High 7.4
- Published: Mar 16, 2026
- Affected: fixed in 2.14.2.
- Fixed in 2.14.2 (released Dec 31, 2025, 75 days before disclosure).
- The latest release, 4.1.6, is not affected.

### [CVE-2025-62801](https://cve.now/CVE-2025-62801): FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server\_name

- Severity: Medium 5.4
- Published: Oct 28, 2025
- Affected: fixed in 2.13.0.
- Fixed in 2.13.0 (released Oct 25, 2025, 3 days before disclosure).
- The latest release, 4.1.6, is not affected.

### [CVE-2025-62800](https://cve.now/CVE-2025-62800): FastMCP vulnerable to reflected XSS in client's callback page

- Severity: Medium 5.3
- Published: Oct 28, 2025
- Affected: fixed in 2.13.0.
- Fixed in 2.13.0 (released Oct 25, 2025, 3 days before disclosure).
- The latest release, 4.1.6, is not affected.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/fastmcp
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
