# eventlet (PyPI) vulnerabilities

3 known vulnerabilities (1 high, 2 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://pypi.org/project/eventlet/

## Advisories (3)

### [CVE-2025-58068](https://cve.now/CVE-2025-58068): Eventlet affected by HTTP request smuggling in unparsed trailers

- Severity: Medium 6.3
- Published: Aug 29, 2025
- Affected: fixed in 0.40.3.

### [CVE-2023-29483](https://cve.now/CVE-2023-29483): eventlet before 0.35.2, as used in dnspython before 2.6.0, allows remote attackers to interfere with DNS name resolution by quickly…

- Severity: High 7.0
- Published: Apr 11, 2024
- Affected: fixed in 0.35.2.

### [CVE-2021-21419](https://cve.now/CVE-2021-21419): Improper Handling of Highly Compressed Data (Data Amplification) and Memory Allocation with Excessive Size Value in eventlet

- Severity: Medium 5.3
- Published: May 7, 2021
- Affected: from 0.10.0, fixed in 0.31.0; from 0.10, fixed in 0.31.0.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/eventlet
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
