# celery (PyPI) vulnerabilities

2 known vulnerabilities (1 high), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://pypi.org/project/celery/

## Advisories (2)

### [CVE-2021-23727](https://cve.now/CVE-2021-23727): Stored Command Injection

- Severity: High 7.5
- Published: Dec 29, 2021
- Affected: fixed in 5.2.2.

### [CVE-2011-4356](https://cve.now/CVE-2011-4356): Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of…

- Severity: Unrated
- Published: Dec 5, 2011
- Affected: from 2.1, fixed in 2.2.8; from 2.3, fixed in 2.3.4; from 2.4, fixed in 2.4.4; from 2.1.0, fixed in 2.2.8; from 2.3.0, fixed in 2.3.4; from 2.4.0, fixed in 2.4.4.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/celery
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
