# cai-framework (PyPI) vulnerabilities

2 known vulnerabilities (2 critical), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 0.5.10 (Dec 19, 2025): affected by CVE-2026-25130
- Newest unaffected release: Every release is affected by at least one advisory
- Weekly downloads: 554
- Dependents: 0
- Releases: 18 since 0.3.9 (Apr 9, 2025)
- Registry: https://pypi.org/project/cai-framework/
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2026-25130: 0.3.9 to 0.5.10 (through the newest release)
- CVE-2025-67511: 0.3.9 to 0.5.9 (0.5.10 is outside it)

## Advisories (2)

### [CVE-2026-25130](https://cve.now/CVE-2026-25130): Cybersecurity AI vulnerable to command Injection through argument injection in find\_file Agent tool

- Severity: Critical 9.7
- Published: Jan 30, 2026
- Affected: through 0.5.10.
- No fix released. The latest release, 0.5.10, is still affected.

### [CVE-2025-67511](https://cve.now/CVE-2025-67511): Cybersecurity AI (CAI) vulnerable to Command Injection in run\_ssh\_command\_with\_credentials Agent tool

- Severity: Critical 9.7
- Published: Dec 10, 2025
- Affected: through 0.5.9.
- Fixed in 0.5.10 (released Dec 19, 2025, 9 days after disclosure), the first release outside every affected range (no listed fixed version clears them all).
- The latest release, 0.5.10, is not affected.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/cai-framework
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
