Skip to main content
← PyPI

beaker

2 known vulnerabilities, with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
2
Registry
PyPI

Advisories 2

  • The Beaker library through 1.11.0 for Python is affected by deserialization of untrusted data, which could lead to arbitrary code execution.

    Affected: through 1.11.0; all versions.

  • Beaker before 1.6.4, when using PyCrypto to encrypt sessions, uses AES in ECB cipher mode, which might allow remote attackers to obtain…

    Affected: fixed in 1.6.5.post1; fixed in 1.6.4.