# ansible-core (PyPI) vulnerabilities

8 known vulnerabilities (3 high, 5 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Weekly downloads: 4M
- Dependents: 318
- Registry: https://pypi.org/project/ansible-core/

## Advisories (8)

### [CVE-2026-123036](https://cve.now/CVE-2026-123036): A flaw was found in ansible-core.

- Severity: Medium 5.5
- Published: Nov 5, 2026
- Affected: from 2.19.0, fixed in 2.23.0.

### [CVE-2026-11332](https://cve.now/CVE-2026-11332): Ansible-core: argument injection in ansible-galaxy role install leads to arbitrary code execution

- Severity: High 7.8
- Published: Jun 5, 2026
- Affected: fixed in 2.16.19rc1; from 2.17.0b1, fixed in 2.18.18rc1; from 2.19.0b1, fixed in 2.19.11rc1; from 2.20.0b1, fixed in 2.20.7rc1; from 2.21.0b1, fixed in 2.21.1rc1; fixed in 2.16.19rc1; from 2.17.0b1, fixed in 2.18.18rc1; from 2.19.0b1, fixed in 2.19.11rc1; from 2.20.0b1, fixed in 2.20.7rc1; from 2.21.0b1, fixed in 2.21.1rc1.

### [CVE-2024-11079](https://cve.now/CVE-2024-11079): Ansible-core: unsafe tagging bypass via hostvars object in ansible-core

- Severity: Medium 5.5
- Published: Nov 11, 2024
- Affected: from 2.18.0b1, fixed in 2.18.1rc1; from 2.17.0b1, fixed in 2.17.7rc1; fixed in 2.16.14rc1; fixed in 2.16.14rc1; from 2.17.0b1, fixed in 2.17.7rc1; from 2.18.0b1, fixed in 2.18.1rc1.

### [CVE-2024-9902](https://cve.now/CVE-2024-9902): Ansible-core: ansible-core user may read/write unauthorized content

- Severity: Medium 6.3
- Published: Nov 6, 2024
- Affected: fixed in 2.14.18rc1; from 2.15.0b1, fixed in 2.15.13rc1; from 2.16.0b1, fixed in 2.16.13rc1; from 2.17.0b1, fixed in 2.17.6rc1; from 2.18.0b1, fixed in 2.18.0rc2; fixed in 2.14.18rc1; from 2.15.0b1, fixed in 2.15.13rc1; from 2.16.0b1, fixed in 2.16.13rc1; from 2.17.0b1, fixed in 2.17.6rc1; from 2.18.0b1, fixed in 2.18.0rc2.

### [CVE-2024-8775](https://cve.now/CVE-2024-8775): Ansible-core: exposure of sensitive information in ansible vault files due to improper logging

- Severity: Medium 5.5
- Published: Sep 14, 2024
- Affected: from 2.17.0b1, fixed in 2.17.6; fixed in 2.16.13; fixed in 2.16.13; from 2.17.0b1, fixed in 2.17.6.

### [CVE-2024-0690](https://cve.now/CVE-2024-0690): Ansible-core: possible information leak in tasks that ignore ansible\_no\_log configuration

- Severity: Medium 5.0
- Published: Feb 6, 2024
- Affected: fixed in 2.14.14; from 2.16.0, fixed in 2.16.3; from 2.15.0, fixed in 2.15.9; fixed in 2.14.4; from 2.15.0, fixed in 2.15.9; from 2.16.0, fixed in 2.16.3.

### [CVE-2023-5764](https://cve.now/CVE-2023-5764): Ansible: template injection

- Severity: High 7.1
- Published: Dec 12, 2023
- Affected: from 2.16.0, fixed in 2.16.1; from 2.15.0, fixed in 2.15.8; fixed in 2.14.12; fixed in 2.14.12; from 2.15.0, fixed in 2.15.8; from 2.16.0, fixed in 2.16.1.

### [CVE-2023-4237](https://cve.now/CVE-2023-4237): Platform: ec2\_key module prints out the private key directly to the standard output

- Severity: High 7.3
- Published: Oct 4, 2023
- Affected: from 2.8.0, through 2.15.2.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/ansible-core
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
