# zendframework/zend-db (Packagist) vulnerabilities

2 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://packagist.org/packages/zendframework/zend-db

## Advisories (2)

### [CVE-2014-8089](https://cve.now/CVE-2014-8089): SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP…

- Severity: Unrated
- Published: Feb 17, 2020
- Affected: from 2.0.0, fixed in 2.0.99; from 2.1.0, fixed in 2.1.99; from 2.2.0, fixed in 2.2.8; from 2.3.0, fixed in 2.3.3.

### [CVE-2015-0270](https://cve.now/CVE-2015-0270): Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\\Db adapter.

- Severity: Unrated
- Published: Oct 25, 2019
- Affected: fixed in 2.2.10; from 2.3.0, fixed in 2.3.5.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/packagist/zendframework/zend-db
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
