# yiisoft/yii (Packagist) vulnerabilities

4 known vulnerabilities (2 high, 1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://packagist.org/packages/yiisoft/yii

## Advisories (4)

### [CVE-2025-32027](https://cve.now/CVE-2025-32027): Yii does not prevent XSS in scenarios where fallback error renderer is used

- Severity: Medium 6.1
- Published: Apr 10, 2025
- Affected: fixed in 1.1.31.

### [CVE-2023-47130](https://cve.now/CVE-2023-47130): Unsafe deserialization of user data in yiisoft/yii

- Severity: High 8.1
- Published: Nov 14, 2023
- Affected: fixed in 1.1.29.

### [CVE-2022-41922](https://cve.now/CVE-2022-41922): yiisoft/yii before v1.1.27 vulnerable to Remote Code Execution if the application calls \`unserialize()\` on arbitrary user input

- Severity: High 8.1
- Published: Nov 23, 2022
- Affected: fixed in 1.1.27.

### [CVE-2014-4672](https://cve.now/CVE-2014-4672): The CDetailView widget in Yii PHP Framework 1.1.14 allows remote attackers to execute arbitrary PHP scripts via vectors related to the…

- Severity: Unrated
- Published: Jul 3, 2014
- Affected: from 1.1.14, fixed in 1.1.15.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/packagist/yiisoft/yii
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
