# typo3/cms-install (Packagist) vulnerabilities

7 known vulnerabilities (1 high, 2 low), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://packagist.org/packages/typo3/cms-install

## Advisories (7)

### [CVE-2026-19418](https://cve.now/CVE-2026-19418): TYPO3 CMS - Broken Access Control in Backend and Install Tool

- Severity: High 7.3
- Published: Aug 11, 2026
- Affected: from 14.0.0, fixed in 14.3.6.

### [CVE-2024-55891](https://cve.now/CVE-2024-55891): Information Disclosure via Exception Handling/Logger in TYPO3

- Severity: Low 3.1
- Published: Jan 14, 2025
- Affected: from 13.4.2, fixed in 13.4.3.

### [CVE-2023-47126](https://cve.now/CVE-2023-47126): Information Disclosure in Install Tool in typo3/cms-install

- Severity: Low 3.7
- Published: Nov 14, 2023
- Affected: from 12.2.0, fixed in 12.4.8.

### [CVE-2010-3671](https://cve.now/CVE-2010-3671): TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 is open to a session fixation attack which allows…

- Severity: Unrated
- Published: Nov 5, 2019
- Affected: fixed in 4.1.14; from 4.2.0, fixed in 4.2.13; from 4.3.0, fixed in 4.3.4; from 4.4.0, fixed in 4.4.1.

### [CVE-2010-3666](https://cve.now/CVE-2010-3666): TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 contains insecure randomness in the uniqid function.

- Severity: Unrated
- Published: Nov 4, 2019
- Affected: fixed in 4.1.14; from 4.2.0, fixed in 4.2.13; from 4.3.0, fixed in 4.3.4; from 4.4.0, fixed in 4.4.1.

### [CVE-2010-5100](https://cve.now/CVE-2010-5100): Multiple cross-site scripting (XSS) vulnerabilities in the Install Tool in TYPO3 4.2.x before 4.2.16, 4.3.x before 4.3.9, and 4.4.x before…

- Severity: Unrated
- Published: May 21, 2012
- Affected: from 4.2.0, fixed in 4.2.16; from 4.3.0, fixed in 4.3.9; from 4.4.0, fixed in 4.4.5.

### [CVE-2009-3636](https://cve.now/CVE-2009-3636): Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before…

- Severity: Unrated
- Published: Nov 2, 2009
- Affected: through 4.0.13; from 4.1.0, fixed in 4.1.13; from 4.2.0, fixed in 4.2.10; from 4.3alpha1, fixed in 4.3beta2.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/packagist/typo3/cms-install
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
