# twbs/bootstrap (Packagist) vulnerabilities

7 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://packagist.org/packages/twbs/bootstrap

## Advisories (7)

### [CVE-2019-8331](https://cve.now/CVE-2019-8331): In Bootstrap before 3.4.1 and 4.3.x before 4.3.1, XSS is possible in the tooltip or popover data-template attribute.

- Severity: Unrated
- Published: Feb 20, 2019
- Affected: from 3.0.0, fixed in 3.4.1; from 4.0.0, fixed in 4.3.1.

### [CVE-2018-20677](https://cve.now/CVE-2018-20677): In Bootstrap before 3.4.0, XSS is possible in the affix configuration target property.

- Severity: Unrated
- Published: Jan 9, 2019
- Affected: fixed in 3.4.0.

### [CVE-2018-20676](https://cve.now/CVE-2018-20676): In Bootstrap before 3.4.0, XSS is possible in the tooltip data-viewport attribute.

- Severity: Unrated
- Published: Jan 9, 2019
- Affected: fixed in 3.4.0.

### [CVE-2016-10735](https://cve.now/CVE-2016-10735): In Bootstrap 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute, a different vulnerability…

- Severity: Unrated
- Published: Jan 9, 2019
- Affected: from 2.0.4, fixed in 3.4.0; from 4.0.0-beta, fixed in 4.0.0-beta.2.

### [CVE-2018-14042](https://cve.now/CVE-2018-14042): In Bootstrap before 4.1.2, XSS is possible in the data-container property of tooltip.

- Severity: Unrated
- Published: Jul 13, 2018
- Affected: from 4.0.0, fixed in 4.1.2; from 2.3.0, fixed in 3.4.0.

### [CVE-2018-14041](https://cve.now/CVE-2018-14041): In Bootstrap before 4.1.2, XSS is possible in the data-target property of scrollspy.

- Severity: Unrated
- Published: Jul 13, 2018
- Affected: from 4.0.0, fixed in 4.1.2.

### [CVE-2018-14040](https://cve.now/CVE-2018-14040): In Bootstrap before 4.1.2, XSS is possible in the collapse data-parent attribute.

- Severity: Unrated
- Published: Jul 13, 2018
- Affected: from 2.3.0, fixed in 3.4.0; from 4.0.0, fixed in 4.1.2.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/packagist/twbs/bootstrap
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
