Skip to main content
← Packagist

genix/cms

18 known vulnerabilities, with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
18
Registry
Packagist

Advisories 18

  • In Genixcms v1.1.11, a stored Cross-Site Scripting (XSS) vulnerability exists in /gxadmin/index.php?page=themes&view=options" via the…

    Affected: through 1.1.11.

  • Cross-site scripting (XSS) vulnerability in GeniXCMS 1.1.0 allows remote authenticated users to inject arbitrary web script or HTML via…

    Affected: versions 1.1.0.

  • GeniXCMS 1.1.5 has XSS via the from, id, lang, menuid, mod, q, status, term, to, or token parameter.

    Affected: through 1.1.5.

  • Multiple SQL injection vulnerabilities in inc/lib/User.class.php in MetalGenix GeniXCMS before 0.0.3-patch allow remote attackers to…

    Affected: through 0.0.3.

  • In GeniXCMS 1.1.4, gxadmin/index.php has XSS via the Menu ID field in a page=menus request.

    Affected: versions 1.1.4.

  • In the Upload Modules page in GeniXCMS 1.1.4, remote authenticated users can execute arbitrary PHP code via a .php file in a ZIP archive…

    Affected: versions 1.1.4.

  • In the Install Themes page in GeniXCMS 1.1.4, remote authenticated users can execute arbitrary PHP code via a .php file in a ZIP archive…

    Affected: versions 1.1.4.

  • In GeniXCMS 1.1.4, /inc/lib/Control/Backend/menus.control.php has XSS via the id parameter.

    Affected: versions 1.1.4.

  • In GeniXCMS 1.1.4, /inc/lib/backend/menus.control.php has XSS via the id parameter.

    Affected: versions 1.1.4.

  • GeniXCMS before 1.1.0 allows remote attackers to cause a denial of service (account blockage) by leveraging the mishandling of certain…

    Affected: fixed in 1.1.0.

  • forgotpassword.php in GeniXCMS 1.0.2 lacks a rate limit, which might allow remote attackers to cause a denial of service (login inability)…

    Affected: fixed in 1.1.2.

  • GeniXCMS 1.0.2 has XSS triggered by a comment that is mishandled during a publish operation by an administrator, as demonstrated by a…

    Affected: fixed in 1.1.0.

  • GeniXCMS 1.0.2 has XSS triggered by an authenticated user who submits a page, as demonstrated by a crafted oncut attribute in a B element.

    Affected: fixed in 1.1.1.

  • GeniXCMS 1.0.2 allows remote attackers to bypass the alertDanger MSG_USER_EMAIL_EXIST protection mechanism via a…

    Affected: fixed in 1.1.0.

  • GeniXCMS 1.0.2 has SQL Injection in inc/lib/Control/Backend/menus.control.php via the menuid parameter.

    Affected: fixed in 1.1.0.

Show all 18 advisoriesShow fewer advisories
  • GeniXCMS 1.0.2 has XSS triggered by an authenticated comment that is mishandled during a mouse operation by an administrator.

    Affected: fixed in 1.1.0.

  • SQL injection vulnerability in inc/lib/Control/Backend/posts.control.php in GeniXCMS 0.0.8 allows remote authenticated administrators to…

    Affected: fixed in 1.0.0.

  • SQL injection vulnerability in register.php in GeniXCMS before 1.0.0 allows remote attackers to execute arbitrary SQL commands via the…

    Affected: fixed in 1.0.0.