# codeigniter4/framework (Packagist) vulnerabilities

19 known vulnerabilities (6 critical, 6 high, 4 medium, 1 low), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://packagist.org/packages/codeigniter4/framework

## Advisories (19)

### [CVE-2026-63223](https://cve.now/CVE-2026-63223): CodeIgniter: Uploaded file extension validation bypass in is\_image and mime\_in rules

- Severity: Critical 9.8
- Published: Jul 31, 2026
- Affected: fixed in 4.7.4.

### [CVE-2026-63222](https://cve.now/CVE-2026-63222): CodeIgniter: Path traversal in UploadedFile::move() when using client-provided filenames

- Severity: High 7.5
- Published: Jul 31, 2026
- Affected: fixed in 4.7.4.

### [CVE-2026-63221](https://cve.now/CVE-2026-63221): CodeIgniter: SQL injection is possible via Query Builder deleteBatch() when used with where() conditions

- Severity: Critical 9.4
- Published: Jul 31, 2026
- Affected: from 4.3.0, fixed in 4.7.4.

### [CVE-2026-63220](https://cve.now/CVE-2026-63220): CodeIgniter: Spoofable forwarded HTTPS headers in IncomingRequest::isSecure()

- Severity: Medium 4.8
- Published: Jul 31, 2026
- Affected: fixed in 4.7.4.

### [CVE-2026-48062](https://cve.now/CVE-2026-48062): CodeIgniter: Uploaded file extension validation bypass in \`ext\_in\` rule

- Severity: Critical 9.8
- Published: Jul 17, 2026
- Affected: fixed in 4.7.3.

### [CVE-2025-54418](https://cve.now/CVE-2025-54418): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability

- Severity: Critical 9.8
- Published: Jul 28, 2025
- Affected: fixed in 4.6.2.

### [CVE-2025-24013](https://cve.now/CVE-2025-24013): CodeIgniter validation of header name and value

- Severity: Medium 5.3
- Published: Jan 20, 2025
- Affected: fixed in 4.5.8.

### [CVE-2024-29904](https://cve.now/CVE-2024-29904): CodeIgniter4 Language class DoS Vulnerability

- Severity: High 7.5
- Published: Mar 29, 2024
- Affected: fixed in 4.4.7.

### [CVE-2023-46240](https://cve.now/CVE-2023-46240): CodeIgniter4 vulnerable to information disclosure when detailed error report is displayed in production environment

- Severity: High 7.5
- Published: Oct 31, 2023
- Affected: fixed in 4.4.3.

### [CVE-2023-32692](https://cve.now/CVE-2023-32692): Remote Code Execution Vulnerability in Validation Placeholders

- Severity: Critical 9.8
- Published: May 30, 2023
- Affected: fixed in 4.3.5.

### [CVE-2022-46170](https://cve.now/CVE-2022-46170): CodeIgniter is vulnerable to improper authentication via Session Handlers

- Severity: High 8.6
- Published: Dec 22, 2022
- Affected: fixed in 4.2.11.

### [CVE-2022-23556](https://cve.now/CVE-2022-23556): CodeIgniter is vulnerable to IP address spoofing when using proxy

- Severity: High 7.0
- Published: Dec 22, 2022
- Affected: fixed in 4.2.11.

### [CVE-2022-39284](https://cve.now/CVE-2022-39284): Secure or HttpOnly flag set in Config\\Cookie is not reflected in Cookies issued in Codeigniter4

- Severity: Low 2.6
- Published: Oct 6, 2022
- Affected: fixed in 4.2.7.

### [CVE-2022-24712](https://cve.now/CVE-2022-24712): Cross-Site Request Forgery (CSRF) Protection Bypass Vulnerability in CodeIgniter4

- Severity: Medium 6.3
- Published: Feb 28, 2022
- Affected: fixed in 4.1.9.

### [CVE-2022-24711](https://cve.now/CVE-2022-24711): Remote CLI Command Execution Vulnerability in CodeIgniter4

- Severity: Critical 9.4
- Published: Feb 28, 2022
- Affected: fixed in 4.1.9.

### [CVE-2022-21715](https://cve.now/CVE-2022-21715): Cross-site Scripting Vulnerability in CodeIgniter4

- Severity: Medium 5.4
- Published: Jan 24, 2022
- Affected: fixed in 4.1.8.

### [CVE-2022-21647](https://cve.now/CVE-2022-21647): Deserialization of Untrusted Data in Codeigniter4

- Severity: High 7.7
- Published: Jan 4, 2022
- Affected: fixed in 4.1.6.

### [CVE-2020-10793](https://cve.now/CVE-2020-10793): CodeIgniter through 4.0.0 allows remote attackers to gain privileges via a modified Email ID to the "Select Role of the User" page.

- Severity: Unrated
- Published: Mar 23, 2020
- Affected: through 4.0.0.

### [CVE-2017-1000247](https://cve.now/CVE-2017-1000247): British Columbia Institute of Technology CodeIgniter 3.1.3 is vulnerable to HTTP Header Injection in the set\_status\_header() common…

- Severity: Unrated
- Published: Nov 17, 2017
- Affected: from 3.1.3, fixed in 3.1.4.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/packagist/codeigniter4/framework
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
