# ckeditor/ckeditor (Packagist) vulnerabilities

4 known vulnerabilities (1 high, 2 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://packagist.org/packages/ckeditor/ckeditor

## Advisories (4)

### [CVE-2024-43407](https://cve.now/CVE-2024-43407): Code Snippet GeSHi plugin has reflected cross-site scripting (XSS) vulnerability

- Severity: Medium 6.1
- Published: Aug 21, 2024
- Affected: fixed in 4.25.0.

### [CVE-2024-24815](https://cve.now/CVE-2024-24815): CKEditor4 Cross-site scripting (XSS) vulnerability caused by incorrect CDATA detection

- Severity: Medium 6.1
- Published: Feb 7, 2024
- Affected: fixed in 4.24.0.

### [CVE-2021-41165](https://cve.now/CVE-2021-41165): HTML comments vulnerability allowing to execute JavaScript code

- Severity: High 8.2
- Published: Nov 17, 2021
- Affected: fixed in 4.17.0.

### [CVE-2014-5191](https://cve.now/CVE-2014-5191): Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web…

- Severity: Unrated
- Published: Aug 7, 2014
- Affected: fixed in 4.4.3.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/packagist/ckeditor/ckeditor
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
