Skip to main content
← Packagist

appwrite/server-ce

4 known vulnerabilities (1 critical, 3 high), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 1 critical, 3 high
Registry
Packagist

Advisories 4

  • The ACME-challenge endpoint in Appwrite 0.5.0 through 0.12.x before 0.12.2 allows remote attackers to read arbitrary local files via ../…

    Affected: from 0.5.0, fixed in 0.12.2.

  • Appwrite up to v1.2.1 was discovered to contain a Server-Side Request Forgery (SSRF) via the component /v1/avatars/favicon.

    Affected: through 1.2.1.

  • CVE-2022-2925Critical 9.0

    Cross-site Scripting (XSS) - Stored in appwrite/appwrite

    Affected: fixed in 1.0.0-RC1.

  • Prototype Pollution

    Affected: from 0.12.0, fixed in 0.12.2; fixed in 0.11.1.