Skip to main content
← Packagist

adodb/adodb-php

5 known vulnerabilities (3 critical), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
5 · 3 critical
Registry
Packagist

Advisories 5

  • CVE-2025-54119Critical 10.0

    ADOdb's sqlite3 driver allows SQL injection

    Affected: fixed in 5.22.10.

  • CVE-2025-46337Critical 10.0

    SQL injection in ADOdb PostgreSQL driver pg_insert_id() method

    Affected: fixed in 5.22.9.

  • CVE-2021-3850Critical 9.1

    Authentication Bypass by Primary Weakness in adodb/adodb

    Affected: fixed in 5.20.21; from 5.21.0, fixed in 5.21.4.

  • Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via…

    Affected: fixed in 5.20.6.

  • The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL…

    Affected: from 5.0, fixed in 5.20.7.