- Latest release
- Not known: cve.now hasn't read this package's releases
- Newest unaffected release
- Not known without release data
- Advisories
- 26 · 1 critical, 18 high, 7 medium
- Registry
- NuGet
Advisories 26
Microsoft Security Advisory CVE-2026-111497 - .NET Brotli Decoder Out-of-bounds Write Vulnerability
Affected: from 8.0.0, fixed in 8.0.33; from 9.0.0, fixed in 9.0.22; from 10.0.0, fixed in 10.0.14; from 11.0.0-preview.1, fixed in 11.0.0-rc.3.26522.148.
- CVE-2026-50659Medium 6.5
.NET Spoofing Vulnerability
Affected: from 10.0.0, fixed in 10.0.10; from 9.0.0, fixed in 9.0.18; from 8.0.0, fixed in 8.0.29.
- CVE-2026-50651High 7.5
.NET Denial of Service Vulnerability
Affected: from 10.0.0, fixed in 10.0.10; from 9.0.0, fixed in 9.0.18; from 8.0.0, fixed in 8.0.29.
- CVE-2026-50528High 8.2
.NET Security Feature Bypass Vulnerability
Affected: from 10.0.0, fixed in 10.0.10; from 9.0.0, fixed in 9.0.18; from 8.0.0, fixed in 8.0.29.
- CVE-2026-50524High 7.5
.NET Framework Denial of Service Vulnerability
Affected: from 10.0.0, fixed in 10.0.10; from 9.0.0, fixed in 9.0.18; from 8.0.0, fixed in 8.0.29.
- CVE-2026-47302High 7.5
.NET Denial of Service Vulnerability
Affected: from 10.0.0, fixed in 10.0.10; from 9.0.0, fixed in 9.0.18; from 8.0.0, fixed in 8.0.29.
- CVE-2026-57108High 7.5
.NET Denial of Service Vulnerability
Affected: from 10.0.0, fixed in 10.0.10; from 9.0.0, fixed in 9.0.18; from 8.0.0, fixed in 8.0.29.
- CVE-2026-45491Medium 6.2
.NET Tampering Vulnerability
Affected: from 8.0.0, fixed in 8.0.28; from 9.0.0, fixed in 9.0.17; from 10.0.0, fixed in 10.0.9.
- CVE-2026-32178High 7.5
.NET Spoofing Vulnerability
Affected: from 10.0.0, fixed in 10.0.6; from 9.0.0, fixed in 9.0.15; from 8.0.0, fixed in 8.0.26.
- CVE-2026-26127High 7.5
.NET Denial of Service Vulnerability
Affected: from 9.0.0, fixed in 9.0.14; from 10.0.0, fixed in 10.0.4.
- CVE-2025-55248Medium 4.8
.NET, .NET Framework, and Visual Studio Information Disclosure Vulnerability
Affected: from 9.0.0, fixed in 9.0.10; from 8.0.0, fixed in 8.0.21.
- CVE-2025-30399High 7.5
.NET and Visual Studio Remote Code Execution Vulnerability
Affected: from 9.0.0, fixed in 9.0.6; from 8.0.0, fixed in 8.0.17.
- CVE-2020-36846Critical 9.8
IO::Compress::Brotli versions prior to 0.007 for Perl have an integer overflow in the bundled Brotli C library
Affected: from 6.0.0, fixed in 6.0.3.
- CVE-2025-21172High 7.5
.NET and Visual Studio Remote Code Execution Vulnerability
Affected: from 9.0.0, fixed in 9.0.1; from 8.0.0, fixed in 8.0.12.
- CVE-2025-21176High 8.8
.NET, .NET Framework, and Visual Studio Remote Code Execution Vulnerability
Affected: from 9.0.0, fixed in 9.0.1; from 8.0.0, fixed in 8.0.12.
Show all 26 advisoriesShow fewer advisories
- CVE-2025-21171High 7.5
.NET Remote Code Execution Vulnerability
Affected: from 9.0.0, fixed in 9.0.1.
- CVE-2024-38167Medium 6.5
.NET and Visual Studio Information Disclosure Vulnerability
Affected: from 8.0.0, fixed in 8.0.8.
- CVE-2024-38095High 7.5
.NET and Visual Studio Denial of Service Vulnerability
Affected: from 8.0.0, fixed in 8.0.7; from 6.0.0, fixed in 6.0.32.
- CVE-2024-30045Medium 6.3
.NET and Visual Studio Remote Code Execution Vulnerability
Affected: from 7.0.0, fixed in 7.0.19; from 8.0.0, fixed in 8.0.5.
- CVE-2024-21392High 7.5
.NET and Visual Studio Denial of Service Vulnerability
Affected: from 7.0.0-preview.1.22076.8, fixed in 7.0.17; from 8.0.0, fixed in 8.0.3.
- CVE-2023-29331High 7.5
.NET, .NET Framework, and Visual Studio Denial of Service Vulnerability
Affected: from 6.0.0, fixed in 6.0.18; from 7.0.0, fixed in 7.0.7.
- CVE-2023-24936High 7.5
.NET, .NET Framework, and Visual Studio Elevation of Privilege Vulnerability
Affected: from 7.0.0, fixed in 7.0.7; from 6.0.0, fixed in 6.0.18.
- CVE-2023-33128High 7.3
.NET and Visual Studio Remote Code Execution Vulnerability
Affected: from 7.0.0, fixed in 7.0.7.
- CVE-2023-21538High 7.5
.NET Denial of Service Vulnerability
Affected: from 6.0.0, fixed in 6.0.13.
- CVE-2022-24512Medium 6.3
.NET and Visual Studio Remote Code Execution Vulnerability
Affected: from 6.0.0, fixed in 6.0.3.
- CVE-2020-8927Medium 5.3
Buffer overflow in Brotli library
Affected: from 6.0.0, fixed in 6.0.3.