# yapi-vendor (npm) vulnerabilities

4 known vulnerabilities (1 high, 1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 1.12.0 (Nov 1, 2022): affected by CVE-2025-70058
- Newest unaffected release: Every release is affected by at least one advisory
- Weekly downloads: 552
- Dependents: 0
- Releases: 41 since 1.4.1 (Nov 6, 2018)
- Registry: https://www.npmjs.com/package/yapi-vendor
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2025-70058: 1.4.1 to 1.12.0 (through the newest release)
- CVE-2021-36686: 1.4.1 to 1.9.1 (1.9.2 is outside it)
- CVE-2021-27884: 1.4.1 to 1.9.2 (1.10.1 is outside it)
- CVE-2018-17574: no published release is affected

## Advisories (4)

### [CVE-2025-70058](https://cve.now/CVE-2025-70058): An issue pertaining to CWE-295: Improper Certificate Validation was discovered in YMFE yapi v1.12.0.

- Severity: High 7.4
- Published: Feb 23, 2026
- Affected: through 1.12.0.
- No fix released. The latest release, 1.12.0, is still affected.
- 100% of yapi-vendor downloads last week were affected versions (499).

### [CVE-2021-36686](https://cve.now/CVE-2021-36686): Cross Site Scripting (XSS) vulnerability in yapi 1.9.1 allows attackers to execute arbitrary code via the /interface/api edit page.

- Severity: Medium 5.4
- Published: Jan 26, 2023
- Affected: through 1.9.1.
- Fixed in 1.9.2 (released May 29, 2020, 972 days before disclosure), the first release outside every affected range (no listed fixed version clears them all).
- The latest release, 1.12.0, is not affected.
- 48% of yapi-vendor downloads last week were affected versions (241).

### [CVE-2021-27884](https://cve.now/CVE-2021-27884): Weak JSON Web Token (JWT) signing secret generation in YMFE YApi through 1.9.2 allows recreation of other users' JWT tokens.

- Severity: Unrated
- Published: Mar 1, 2021
- Affected: fixed in 1.9.3.
- Fixed in 1.10.1 (released Aug 30, 2021, 182 days after disclosure, the advisory names 1.9.3, which was never published).
- The latest release, 1.12.0, is not affected.
- 53% of yapi-vendor downloads last week were affected versions (266).

### [CVE-2018-17574](https://cve.now/CVE-2018-17574): An issue was discovered in YMFE YApi 1.3.23.

- Severity: Unrated
- Published: Sep 28, 2018
- Affected: fixed in 1.3.23.
- Fixed in 1.4.1 (released Nov 6, 2018, 39 days after disclosure, the advisory names 1.3.23, which was never published).
- The latest release, 1.12.0, is not affected.
- 0% of yapi-vendor downloads last week were affected versions (0).

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/yapi-vendor
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
