# webpack (npm) vulnerabilities

4 known vulnerabilities (1 critical, 1 medium, 2 low), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://www.npmjs.com/package/webpack

## Advisories (4)

### [CVE-2025-68157](https://cve.now/CVE-2025-68157): webpack buildHttp HttpUriPlugin allowedUris bypass via HTTP redirects

- Severity: Low 3.7
- Published: Feb 5, 2026
- Affected: from 5.49.0, fixed in 5.104.0.

### [CVE-2025-68458](https://cve.now/CVE-2025-68458): webpack buildHttp: allowedUris allow-list bypass via URL userinfo (@) leading to build-time SSRF behavior

- Severity: Low 3.7
- Published: Feb 5, 2026
- Affected: from 5.49.0, fixed in 5.104.1.

### [CVE-2024-43788](https://cve.now/CVE-2024-43788): DOM Clobbering Gadget found in Webpack's AutoPublicPathRuntimeModule that leads to Cross-site Scripting (XSS)

- Severity: Medium 6.4
- Published: Aug 27, 2024
- Affected: from 5.0.0-alpha.0, fixed in 5.94.0.

### [CVE-2023-28154](https://cve.now/CVE-2023-28154): Webpack 5 before 5.76.0 does not avoid cross-realm object access.

- Severity: Critical 9.8
- Published: Mar 13, 2023
- Affected: from 5.0.0, fixed in 5.76.0.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/webpack
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
