Skip to main content
← npm

valine

4 known vulnerabilities, with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4
Registry
npm

Advisories 4

  • Valine v1.4.18 was discovered to contain a remote code execution (RCE) vulnerability which allows attackers to execute arbitrary code via…

    Affected: fixed in 1.5.0.

  • Cross Site Scripting (XSS) vulnerability in xCss Valine v1.4.14 via the nick parameter to /classes/Comment.

    Affected: fixed in 1.4.15.

  • Valine 1.4.14 allows remote attackers to cause a denial of service (application outage) by supplying a ua (aka User-Agent) value that only…

    Affected: through 1.4.14.

  • An issue was discovered in Valine v1.3.3.

    Affected: fixed in 1.3.4.