# swagger-ui (npm) vulnerabilities

4 known vulnerabilities (1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://www.npmjs.com/package/swagger-ui

## Advisories (4)

### [CVE-2018-25031](https://cve.now/CVE-2018-25031): Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks.

- Severity: Medium 4.3
- Published: Mar 11, 2022
- Affected: fixed in 4.1.3.

### [CVE-2016-1000229](https://cve.now/CVE-2016-1000229): swagger-ui has XSS in key names

- Severity: Unrated
- Published: Dec 20, 2019
- Affected: fixed in 2.2.1.

### [CVE-2019-17495](https://cve.now/CVE-2019-17495): A Cascading Style Sheets (CSS) injection vulnerability in Swagger UI before 3.23.11 allows attackers to use the Relative Path Overwrite…

- Severity: Unrated
- Published: Oct 10, 2019
- Affected: fixed in 3.23.11.

### [CVE-2016-5682](https://cve.now/CVE-2016-5682): Swagger-UI before 2.2.1 has XSS via the Default field in the Definitions section.

- Severity: Unrated
- Published: Apr 10, 2017
- Affected: fixed in 2.2.1.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/swagger-ui
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
