Skip to main content
← npm

swagger-ui

4 known vulnerabilities (1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 1 medium
Registry
npm

Advisories 4

  • CVE-2018-25031Medium 4.3

    Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks.

    Affected: fixed in 4.1.3.

  • swagger-ui has XSS in key names

    Affected: fixed in 2.2.1.

  • A Cascading Style Sheets (CSS) injection vulnerability in Swagger UI before 3.23.11 allows attackers to use the Relative Path Overwrite…

    Affected: fixed in 3.23.11.

  • Swagger-UI before 2.2.1 has XSS via the Default field in the Definitions section.

    Affected: fixed in 2.2.1.