# ssri (npm) vulnerabilities

2 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://www.npmjs.com/package/ssri

## Advisories (2)

### [CVE-2021-27290](https://cve.now/CVE-2021-27290): ssri 5.2.2-8.0.0, fixed in 8.0.1, processes SRIs using a regular expression which is vulnerable to a denial of service.

- Severity: Unrated
- Published: Mar 12, 2021
- Affected: from 5.2.2, fixed in 6.0.2; from 7.0.0, fixed in 7.1.1; from 8.0.0, fixed in 8.0.1.

### [CVE-2018-7651](https://cve.now/CVE-2018-7651): index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode…

- Severity: Unrated
- Published: Mar 4, 2018
- Affected: fixed in 5.2.2.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/ssri
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
