Skip to main content
← npm

ssri

2 known vulnerabilities, with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
2
Registry
npm

Advisories 2

  • ssri 5.2.2-8.0.0, fixed in 8.0.1, processes SRIs using a regular expression which is vulnerable to a denial of service.

    Affected: from 5.2.2, fixed in 6.0.2; from 7.0.0, fixed in 7.1.1; from 8.0.0, fixed in 8.0.1.

  • index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode…

    Affected: fixed in 5.2.2.