Skip to main content
← npm

serve-static

2 known vulnerabilities (1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
2 · 1 medium
Registry
npm

Advisories 2

  • CVE-2024-43800Medium 5.0

    serve-static affected by template injection that can lead to XSS

    Affected: fixed in 1.16.0; from 2.0.0, fixed in 2.1.0.

  • Open redirect vulnerability in the serve-static plugin before 1.7.2 for Node.js, when mounted at the root, allows remote attackers to…

    Affected: fixed in 1.7.2; from 1.7.0, fixed in 1.7.2.