# qs (npm) vulnerabilities

10 known vulnerabilities (1 high, 5 medium, 1 low), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://www.npmjs.com/package/qs

## Advisories (10)

### [CVE-2026-110816](https://cve.now/CVE-2026-110816): qs.stringify with arrayFormat comma throws TypeError on array elements that cannot be coerced to a string

- Severity: Medium 5.3
- Published: Oct 14, 2026
- Affected: from 6.7.0, fixed in 6.16.1.

### [CVE-2026-82562](https://cve.now/CVE-2026-82562): qs.parse does not enforce arrayLimit on comma groups under bracket-push keys when throwOnLimitExceeded is set (incomplete fix for…

- Severity: Low 3.7
- Published: Aug 29, 2026
- Affected: from 6.14.2, fixed in 6.16.0.

### [CVE-2026-82417](https://cve.now/CVE-2026-82417): qs.stringify throws TypeError on objects with a non-callable constructor.isBuffer property

- Severity: Medium 5.3
- Published: Aug 29, 2026
- Affected: from 2.2.5, fixed in 6.16.0.

### [CVE-2026-8723](https://cve.now/CVE-2026-8723): qs.stringify crashes on null/undefined entries in comma-format arrays under encodeValuesOnly

- Severity: Medium 5.3
- Published: May 16, 2026
- Affected: from 6.11.1, fixed in 6.15.2.

### [CVE-2026-2391](https://cve.now/CVE-2026-2391): qs's arrayLimit bypass in comma parsing allows denial of service

- Severity: Medium 6.3
- Published: Feb 12, 2026
- Affected: from 6.7.0, fixed in 6.14.2.

### [CVE-2025-15284](https://cve.now/CVE-2025-15284): arrayLimit bypass in bracket notation allows DoS via memory exhaustion

- Severity: Medium 6.3
- Published: Dec 29, 2025
- Affected: fixed in 6.14.1.

### [CVE-2022-24999](https://cve.now/CVE-2022-24999): qs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers to cause a Node process hang for an Express…

- Severity: High 7.5
- Published: Nov 26, 2022
- Affected: from 6.10.0, fixed in 6.10.3; from 6.9.0, fixed in 6.9.7; from 6.8.0, fixed in 6.8.3; from 6.7.0, fixed in 6.7.3; from 6.6.0, fixed in 6.6.1; from 6.5.0, fixed in 6.5.3; from 6.4.0, fixed in 6.4.1; from 6.3.0, fixed in 6.3.3; fixed in 6.2.4.

### [CVE-2014-10064](https://cve.now/CVE-2014-10064): The qs module before 1.0.0 does not have an option or default for specifying object depth and when parsing a string representing a deeply…

- Severity: Unrated
- Published: May 31, 2018
- Affected: fixed in 1.0.0.

### [CVE-2017-1000048](https://cve.now/CVE-2017-1000048): the web framework using ljharb's qs module older than v6.3.2, v6.2.3, v6.1.2, and v6.0.4 is vulnerable to a DoS.

- Severity: Unrated
- Published: Jul 13, 2017
- Affected: fixed in 6.0.4; from 6.1.0, fixed in 6.1.2; from 6.2.0, fixed in 6.2.3; from 6.3.0, fixed in 6.3.2.

### [CVE-2014-7191](https://cve.now/CVE-2014-7191): The qs module before 1.0.0 in Node.js does not call the compact function for array data, which allows remote attackers to cause a denial…

- Severity: Unrated
- Published: Oct 19, 2014
- Affected: fixed in 1.0.0.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/qs
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
