# passport-wsfed-saml2 (npm) vulnerabilities

4 known vulnerabilities (1 critical, 1 high, 1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://www.npmjs.com/package/passport-wsfed-saml2

## Advisories (4)

### [CVE-2025-46573](https://cve.now/CVE-2025-46573): passport-wsfed-saml2 Has SAML Authentication Bypass via Attribute Smuggling

- Severity: High 8.6
- Published: May 6, 2025
- Affected: from 3.0.5, fixed in 4.6.4.

### [CVE-2025-46572](https://cve.now/CVE-2025-46572): passport-wsfed-saml2 Has SAML Authentication Bypass via Signature Wrapping

- Severity: Critical 9.3
- Published: May 6, 2025
- Affected: from 3.0.5, fixed in 4.6.4.

### [CVE-2022-23505](https://cve.now/CVE-2022-23505): Passport-wsfed-saml2 vulnerable to Authentication Bypass for WSFed authentication

- Severity: Medium 5.3
- Published: Dec 13, 2022
- Affected: fixed in 4.6.3.

### [CVE-2017-16897](https://cve.now/CVE-2017-16897): A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions \< 3.0.5.

- Severity: Unrated
- Published: Dec 23, 2017
- Affected: fixed in 3.0.5.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/passport-wsfed-saml2
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
