Skip to main content
← npm

passport-wsfed-saml2

4 known vulnerabilities (1 critical, 1 high, 1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 1 critical, 1 high, 1 medium
Registry
npm

Advisories 4

  • passport-wsfed-saml2 Has SAML Authentication Bypass via Attribute Smuggling

    Affected: from 3.0.5, fixed in 4.6.4.

  • CVE-2025-46572Critical 9.3

    passport-wsfed-saml2 Has SAML Authentication Bypass via Signature Wrapping

    Affected: from 3.0.5, fixed in 4.6.4.

  • CVE-2022-23505Medium 5.3

    Passport-wsfed-saml2 vulnerable to Authentication Bypass for WSFed authentication

    Affected: fixed in 4.6.3.

  • A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions < 3.0.5.

    Affected: fixed in 3.0.5.