# mongo-express (npm) vulnerabilities

4 known vulnerabilities (1 critical, 1 high, 2 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 1.0.2 (Oct 2, 2023): affected by CVE-2023-52555
- Newest unaffected release: Every release is affected by at least one advisory
- Weekly downloads: 2,483
- Dependents: 0
- Releases: 173 since 0.11.0 (May 7, 2012)
- Registry: https://www.npmjs.com/package/mongo-express
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2023-52555: 0.11.0 to 1.0.2 (1.1.0-rc-1 is outside it)
- CVE-2021-21422: 0.11.0 to 1.0.0-alpha.2 (1.0.0-alpha.4 is outside it)
- CVE-2021-23372: 0.11.0 to 0.54.0 (1.0.0-alpha.1 is outside it)
- CVE-2019-10758: 0.11.0 to 0.53.0 (0.54.0 is outside it)

## Advisories (4)

### [CVE-2023-52555](https://cve.now/CVE-2023-52555): In mongo-express 1.0.2, /admin allows CSRF, as demonstrated by deletion of a Collection.

- Severity: Medium 6.1
- Published: Mar 1, 2024
- Affected: through 1.0.2.
- No fix released. The latest release, 1.0.2, is still affected.
- 80% of mongo-express downloads last week were affected versions (2.7K).

### [CVE-2021-21422](https://cve.now/CVE-2021-21422): XSS Vulnerability in mongo-express

- Severity: High 8.1
- Published: Jun 21, 2021
- Affected: fixed in 1.0.0-alpha.4.
- Fixed in 1.0.0-alpha.4 (released Jun 4, 2021, 17 days before disclosure).
- The latest release, 1.0.2, is not affected.
- 57% of mongo-express downloads last week were affected versions (2K).

### [CVE-2021-23372](https://cve.now/CVE-2021-23372): Denial of Service (DoS)

- Severity: Medium 4.4
- Published: Apr 13, 2021
- Affected: through 0.54.0.
- Fixed in 1.0.0 (released Sep 9, 2022, 514 days after disclosure), the first release outside every affected range (no listed fixed version clears them all).
- The latest release, 1.0.2, is not affected.
- 55% of mongo-express downloads last week were affected versions (1.9K).

### [CVE-2019-10758](https://cve.now/CVE-2019-10758): mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the \`toBSON\` method.

- Severity: Critical 9.9 · KEV
- Published: Dec 24, 2019
- Affected: fixed in 0.54.0.
- Fixed in 0.54.0 (released Dec 24, 2019, the day of disclosure).
- The latest release, 1.0.2, is not affected.
- 50% of mongo-express downloads last week were affected versions (1.7K).

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/mongo-express
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
