# lodash (npm) vulnerabilities

10 known vulnerabilities (2 high, 3 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Weekly downloads: 206.5M
- Dependents: 703.2K
- Registry: https://www.npmjs.com/package/lodash

## Advisories (10)

### [CVE-2026-4800](https://cve.now/CVE-2026-4800): lodash vulnerable to Code Injection via \`\_.template\` imports key names

- Severity: High 8.1
- Published: Mar 31, 2026
- Affected: from 4.0.0, fixed in 4.18.0.

### [CVE-2026-2950](https://cve.now/CVE-2026-2950): lodash vulnerable to Prototype Pollution via array path bypass in \`\_.unset\` and \`\_.omit\`

- Severity: Medium 6.5
- Published: Mar 31, 2026
- Affected: fixed in 4.18.0.

### [CVE-2025-13465](https://cve.now/CVE-2025-13465): Prototype Pollution Vulnerability in Lodash \_.unset and \_.omit functions

- Severity: Medium 6.9
- Published: Jan 21, 2026
- Affected: from 4.0.0, fixed in 4.17.23.

### [CVE-2021-23337](https://cve.now/CVE-2021-23337): Command Injection

- Severity: High 7.2
- Published: Feb 15, 2021
- Affected: fixed in 4.17.21.

### [CVE-2020-28500](https://cve.now/CVE-2020-28500): Regular Expression Denial of Service (ReDoS)

- Severity: Medium 5.3
- Published: Feb 15, 2021
- Affected: from 4.0.0, fixed in 4.17.21.

### [CVE-2020-8203](https://cve.now/CVE-2020-8203): Prototype pollution attack when using \_.zipObjectDeep in lodash before 4.17.20.

- Severity: Unrated
- Published: Jul 15, 2020
- Affected: from 3.7.0, fixed in 4.17.19.

### [CVE-2019-10744](https://cve.now/CVE-2019-10744): Versions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution.

- Severity: Unrated
- Published: Jul 25, 2019
- Affected: fixed in 4.17.12.

### [CVE-2019-1010266](https://cve.now/CVE-2019-1010266): lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption.

- Severity: Unrated
- Published: Jul 17, 2019
- Affected: from 4.7.0, fixed in 4.17.11.

### [CVE-2018-16487](https://cve.now/CVE-2018-16487): A prototype pollution vulnerability was found in lodash \<4.17.11 where the functions merge, mergeWith, and defaultsDeep can be tricked…

- Severity: Unrated
- Published: Feb 1, 2019
- Affected: fixed in 4.17.11.

### [CVE-2018-3721](https://cve.now/CVE-2018-3721): lodash node module before 4.17.5 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via defaultsDeep, merge, and…

- Severity: Unrated
- Published: Jun 7, 2018
- Affected: fixed in 4.17.5.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/lodash
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
