# llhttp (npm) vulnerabilities

3 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://www.npmjs.com/package/llhttp

## Advisories (3)

### [CVE-2023-30589](https://cve.now/CVE-2023-30589): The llhttp parser in the http module in Node v20.2.0 does not strictly use the CRLF sequence to delimit HTTP requests.

- Severity: Unrated
- Published: Jun 30, 2023
- Affected: fixed in 8.1.1.

### [CVE-2022-32214](https://cve.now/CVE-2022-32214): The llhttp parser \<v14.20.1, \<v16.17.1 and \<v18.9.1 in the http module in Node.js does not strictly use the CRLF sequence to delimit HTTP…

- Severity: Unrated
- Published: Jul 14, 2022
- Affected: fixed in 6.0.7.

### [CVE-2022-32213](https://cve.now/CVE-2022-32213): The llhttp parser \<v14.20.1, \<v16.17.1 and \<v18.9.1 in the http module in Node.js does not correctly parse and validate Transfer-Encoding…

- Severity: Unrated
- Published: Jul 14, 2022
- Affected: fixed in 6.0.7.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/llhttp
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
