# layui (npm) vulnerabilities

3 known vulnerabilities (1 medium, 1 low), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://www.npmjs.com/package/layui

## Advisories (3)

### [CVE-2024-47075](https://cve.now/CVE-2024-47075): DOM Clobbering gadgets found in layui that lead to Cross-site Scripting

- Severity: Medium 6.4
- Published: Sep 26, 2024
- Affected: fixed in 2.9.17.

### [CVE-2023-50550](https://cve.now/CVE-2023-50550): layui up to v2.74 was discovered to contain a cross-site scripting (XSS) vulnerability via the data-content parameter.

- Severity: Unrated
- Published: Dec 30, 2023
- Affected: fixed in 2.7.5.

### [CVE-2023-3691](https://cve.now/CVE-2023-3691): layui HTML Attribute cross site scripting

- Severity: Low 3.5
- Published: Jul 16, 2023
- Affected: fixed in 2.8.0.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/layui
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
