Skip to main content
← npm

jquery-validation

4 known vulnerabilities (1 high, 3 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 1 high, 3 medium
Registry
npm

Advisories 4

  • CVE-2025-3573Medium 5.3

    Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which…

    Affected: fixed in 1.20.0.

  • jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306

    Affected: fixed in 1.19.5.

  • CVE-2021-43306Medium 5.9

    Exponential ReDoS in jquery-validation

    Affected: fixed in 1.19.4.

  • CVE-2021-21252Medium 5.3

    Regular expression denial of service in jquery-validation

    Affected: fixed in 1.19.3.