Skip to main content
← npm

ip

2 known vulnerabilities (1 critical, 1 high), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
2 · 1 critical, 1 high
Registry
npm

Advisories 2

  • The ip package through 2.0.1 for Node.js might allow SSRF because some IP addresses (such as 127.1, 01200034567, 012.1.2.3…

    Affected: through 2.0.1.

  • CVE-2023-42282Critical 9.8

    The ip package before 1.1.9 for Node.js might allow SSRF because some IP addresses (such as 0x7f.1) are improperly categorized as globally…

    Affected: from 2.0.0, fixed in 2.0.1; fixed in 1.1.9.