# hapi (npm) vulnerabilities

6 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 18.1.0 (Feb 4, 2019): no advisory affects it
- Newest unaffected release: Every release is affected by at least one advisory
- Weekly downloads: 95K
- Dependents: 495
- Releases: 295 since 0.0.1 (Aug 6, 2011)
- Registry: https://www.npmjs.com/package/hapi
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2017-16013: 15.0.1 to 16.1.0 (16.1.1 is outside it)
- CVE-2015-9236: 0.0.1 to 10.5.0 (11.0.0 is outside it)
- CVE-2015-9243: 0.0.1 to 11.1.3 (11.1.4 is outside it)
- CVE-2015-9241: 0.0.1 to 11.1.2 (11.1.3 is outside it)
- CVE-2014-4671: 0.0.1 to 6.0.2 (6.1.0 is outside it)
- CVE-2014-3742: 2.0.0 to 2.1.2 (2.2.0 is outside it)

## Advisories (6)

### [CVE-2017-16013](https://cve.now/CVE-2017-16013): hapi is a web and services application framework.

- Severity: Unrated
- Published: Jun 4, 2018
- Affected: from 15.0.0, fixed in 16.1.1.
- Fixed in 16.1.1 (released Mar 31, 2017, 430 days before disclosure).
- The latest release, 18.1.0, is not affected.
- 2.9% of hapi downloads last week were affected versions (2.7K).

### [CVE-2015-9236](https://cve.now/CVE-2015-9236): Hapi versions less than 11.0.0 implement CORS incorrectly and allowed for configurations that at best returned inconsistent headers and at…

- Severity: Unrated
- Published: May 31, 2018
- Affected: fixed in 11.0.0.
- Fixed in 11.0.0 (released Oct 16, 2015, 958 days before disclosure).
- The latest release, 18.1.0, is not affected.
- 15% of hapi downloads last week were affected versions (13.8K).

### [CVE-2015-9243](https://cve.now/CVE-2015-9243): When server level, connection level or route level CORS configurations in hapi node module before 11.1.4 are combined and when a higher…

- Severity: Unrated
- Published: May 29, 2018
- Affected: fixed in 11.1.4.
- Fixed in 11.1.4 (released Dec 27, 2015, 884 days before disclosure).
- The latest release, 18.1.0, is not affected.
- 15% of hapi downloads last week were affected versions (14.2K).

### [CVE-2015-9241](https://cve.now/CVE-2015-9241): Certain input passed into the If-Modified-Since or Last-Modified headers will cause an 'illegal access' exception to be raised.

- Severity: Unrated
- Published: May 29, 2018
- Affected: fixed in 11.1.3.
- Fixed in 11.1.3 (released Dec 23, 2015, 888 days before disclosure).
- The latest release, 18.1.0, is not affected.
- 15% of hapi downloads last week were affected versions (14.1K).

### [CVE-2014-4671](https://cve.now/CVE-2014-4671): Adobe Flash Player before 13.0.0.231 and 14.x before 14.0.0.145 on Windows and OS X and before 11.2.202.394 on Linux, Adobe AIR before…

- Severity: Unrated
- Published: Jul 9, 2014
- Affected: fixed in 6.1.0.
- Fixed in 6.1.0 (released Jul 16, 2014, 7 days after disclosure).
- The latest release, 18.1.0, is not affected.
- 2.9% of hapi downloads last week were affected versions (2.7K).

### [CVE-2014-3742](https://cve.now/CVE-2014-3742): The hapi server framework 2.0.x and 2.1.x before 2.2.0 for Node.js allows remote attackers to cause a denial of service (file descriptor…

- Severity: Unrated
- Published: May 16, 2014
- Affected: from 2.0.0, fixed in 2.2.0.
- Fixed in 2.2.0 (released Feb 10, 2014, 95 days before disclosure).
- The latest release, 18.1.0, is not affected.
- 0.1% of hapi downloads last week were affected versions (120).

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/hapi
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
