Skip to main content
← npm

hapi

6 known vulnerabilities, with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
6
Weekly downloads
95K
Dependents
495
Registry
npm

Advisories 6

  • hapi is a web and services application framework.

    Affected: from 15.0.0, fixed in 16.1.1.

  • Hapi versions less than 11.0.0 implement CORS incorrectly and allowed for configurations that at best returned inconsistent headers and at…

    Affected: fixed in 11.0.0.

  • When server level, connection level or route level CORS configurations in hapi node module before 11.1.4 are combined and when a higher…

    Affected: fixed in 11.1.4.

  • Certain input passed into the If-Modified-Since or Last-Modified headers will cause an 'illegal access' exception to be raised.

    Affected: fixed in 11.1.3.

  • Adobe Flash Player before 13.0.0.231 and 14.x before 14.0.0.145 on Windows and OS X and before 11.2.202.394 on Linux, Adobe AIR before…

    Affected: fixed in 6.1.0.

  • The hapi server framework 2.0.x and 2.1.x before 2.2.0 for Node.js allows remote attackers to cause a denial of service (file descriptor…

    Affected: from 2.0.0, fixed in 2.2.0.