# froala-editor (npm) vulnerabilities

5 known vulnerabilities (1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://www.npmjs.com/package/froala-editor

## Advisories (5)

### [CVE-2024-51434](https://cve.now/CVE-2024-51434): Inconsistent \<plaintext\> tag parsing allows for XSS in Froala WYSIWYG editor 4.3.0 and earlier.

- Severity: Medium 6.1
- Published: Nov 7, 2024
- Affected: through 4.3.0.

### [CVE-2023-41592](https://cve.now/CVE-2023-41592): Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.

- Severity: Unrated
- Published: Sep 14, 2023
- Affected: from 4.0.1, fixed in 4.1.4.

### [CVE-2020-22864](https://cve.now/CVE-2020-22864): A cross site scripting (XSS) vulnerability in the Insert Video function of Froala WYSIWYG Editor 3.1.0 allows attackers to execute…

- Severity: Unrated
- Published: Oct 26, 2021
- Affected: fixed in 4.0.11.

### [CVE-2021-30109](https://cve.now/CVE-2021-30109): Froala Editor 3.2.6 is affected by Cross Site Scripting (XSS).

- Severity: Unrated
- Published: Apr 5, 2021
- Affected: through 3.2.6.

### [CVE-2019-19935](https://cve.now/CVE-2019-19935): Froala Editor before 3.2.3 allows XSS.

- Severity: Unrated
- Published: Jul 7, 2020
- Affected: fixed in 3.2.3.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/froala-editor
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
