# express-cart (npm) vulnerabilities

4 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://www.npmjs.com/package/express-cart

## Advisories (4)

### [CVE-2020-22403](https://cve.now/CVE-2020-22403): Cross Site Request Forgery (CSRF) vulnerability in Express cart v1.1.16 allows attackers to add an administrator account, add discount…

- Severity: Unrated
- Published: Aug 12, 2021
- Affected: fixed in 1.1.17.

### [CVE-2018-16483](https://cve.now/CVE-2018-16483): A deficiency in the access control in module express-cart \<=1.1.5 allows unprivileged users to add new users to the application as…

- Severity: Unrated
- Published: Feb 1, 2019
- Affected: fixed in 1.1.6.

### [CVE-2018-12457](https://cve.now/CVE-2018-12457): expressCart before 1.1.6 allows remote attackers to create an admin user via a /admin/setup Referer header.

- Severity: Unrated
- Published: Jun 15, 2018
- Affected: fixed in 1.1.6.

### [CVE-2018-3758](https://cve.now/CVE-2018-3758): Unrestricted file upload (RCE) in express-cart module before 1.1.7 allows a privileged user to gain access in the hosting machine.

- Severity: Unrated
- Published: Jun 7, 2018
- Affected: fixed in 1.1.7.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/express-cart
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
