# connect (npm) vulnerabilities

3 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://www.npmjs.com/package/connect

## Advisories (3)

### [CVE-2013-7371](https://cve.now/CVE-2013-7371): node-connects before 2.8.2 has cross site scripting in Sencha Labs Connect middleware (vulnerability due to incomplete fix for…

- Severity: Unrated
- Published: Dec 11, 2019
- Affected: fixed in 2.8.2.

### [CVE-2013-7370](https://cve.now/CVE-2013-7370): node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware

- Severity: Unrated
- Published: Dec 11, 2019
- Affected: fixed in 2.8.1.

### [CVE-2018-3717](https://cve.now/CVE-2018-3717): connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in…

- Severity: Unrated
- Published: Jun 7, 2018
- Affected: fixed in 2.14.0.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/connect
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
