Skip to main content
← npm

code-server

4 known vulnerabilities (3 high), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 3 high
Registry
npm

Advisories 4

  • code-server session cookie can be extracted by having user visit specially crafted proxy URL

    Affected: fixed in 4.99.4.

  • Versions of the package code-server before 4.10.1 are vulnerable to Missing Origin Validation in WebSockets handshakes.

    Affected: fixed in 4.10.1.

  • Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0, allows attackers to execute arbitrary code via crafted…

    Affected: fixed in 3.12.0.

  • Inefficient Regular Expression Complexity in cdr/code-server

    Affected: fixed in 3.12.0.