# @ckeditor/ckeditor5-engine (npm) vulnerabilities

3 known vulnerabilities (1 high, 1 medium, 1 low), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 49.1.0 (Nov 4, 2026): no advisory affects it
- Newest unaffected release: 49.1.0 (Nov 4, 2026), the latest release
- Weekly downloads: 1.5M
- Dependents: 315
- Releases: 500+ since 47.5.0 (Feb 11, 2026)
- Registry: https://www.npmjs.com/package/@ckeditor/ckeditor5-engine
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2026-116688: 47.5.0-alpha.3 to 47.7.3 (47.7.4 is outside it); 48.0.0 to 48.5.0 (48.5.1 is outside it)
- CVE-2026-116687: 47.5.0-alpha.3 to 47.7.3 (47.7.4 is outside it); 48.0.0 to 48.5.0 (48.5.1 is outside it)
- CVE-2021-21391: 0.0.0-internal-20260224.0 to 0.0.0-nightly-next-20260907.0 (47.5.0-alpha.3 is outside it)

Older releases aren't stored, so the earliest spans may start sooner.

## Advisories (3)

### [CVE-2026-116688](https://cve.now/CVE-2026-116688): CKEditor: Cross-site scripting (XSS) in the engine package

- Severity: High 8.1
- Published: Oct 27, 2026
- Affected: from 45.0.0, fixed in 47.7.4; from 48.0.0, fixed in 48.5.1.
- Fixed in 47.7.4 (released Sep 16, 2026, 41 days before disclosure) and 48.5.1 (released Sep 16, 2026, 41 days before disclosure).
- The latest release, 49.1.0, is not affected.
- 38% of @ckeditor/ckeditor5-engine downloads last week were affected versions (784K).

### [CVE-2026-116687](https://cve.now/CVE-2026-116687): CKEditor: Cross-site scripting (XSS) in the engine package

- Severity: Low 3.1
- Published: Oct 27, 2026
- Affected: from 29.0.0, fixed in 47.7.4; from 48.0.0, fixed in 48.5.1.
- Fixed in 47.7.4 (released Sep 16, 2026, 41 days before disclosure) and 48.5.1 (released Sep 16, 2026, 41 days before disclosure).
- The latest release, 49.1.0, is not affected.
- 75% of @ckeditor/ckeditor5-engine downloads last week were affected versions (1.5M).

### [CVE-2021-21391](https://cve.now/CVE-2021-21391): Regular expression Denial of Service in multiple packages

- Severity: Medium 6.5
- Published: Apr 29, 2021
- Affected: fixed in 27.0.0.
- Fixed in 47.5.0 (released Feb 11, 2026, 1749 days after disclosure, the advisory names 27.0.0, which was never published).
- The latest release, 49.1.0, is not affected.
- 2.1% of @ckeditor/ckeditor5-engine downloads last week were affected versions (43.2K).

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/npm/@ckeditor/ckeditor5-engine
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
