Skip to main content
← Maven

org.owasp.esapi:esapi

5 known vulnerabilities (1 high, 1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
5 · 1 high, 1 medium
Registry
Maven Central

Advisories 5

  • CVE-2022-24891Medium 5.4

    Cross-site Scripting in org.owasp.esapi:esapi -- antisamy-esapi.xml configuration file

    Affected: fixed in 2.3.0.0.

  • Path Traversal in ESAPI

    Affected: fixed in 2.3.0.0.

  • It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.

    Affected: fixed in 2.0GA.

  • The authenticated-encryption feature in the symmetric-encryption implementation in the OWASP Enterprise Security API (ESAPI) for Java 2.x…

    Affected: from 2.0.0.0, fixed in 2.1.0.1.

  • The authenticated-encryption feature in the symmetric-encryption implementation in the OWASP Enterprise Security API (ESAPI) for Java 2.x…

    Affected: from 2.0.0, fixed in 2.1.0.