# org.openidentityplatform.openam:openam-core (Maven) vulnerabilities

5 known vulnerabilities (1 critical, 2 high, 1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 16.1.4 (Oct 22, 2026): no advisory affects it
- Newest unaffected release: 16.1.4 (Oct 22, 2026), the latest release
- Dependents: 56
- Releases: 44 since 14.5.2 (Sep 15, 2020)
- Registry: https://central.sonatype.com/artifact/org.openidentityplatform.openam/openam-core
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2026-45048: 14.5.2 to 16.1.0 (16.1.1 is outside it)
- CVE-2026-44202: 14.5.2 to 16.1.0 (16.1.1 is outside it)
- CVE-2026-62379: 14.5.2 to 16.1.1 (16.1.2 is outside it)
- CVE-2026-53660: 14.5.2 to 16.1.0 (16.1.1 is outside it)
- CVE-2022-34298: 14.5.2 to 14.6.5 (14.6.6 is outside it)

## Advisories (5)

### [CVE-2026-45048](https://cve.now/CVE-2026-45048): OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC

- Severity: High 8.5
- Published: Sep 15, 2026
- Affected: fixed in 16.1.1.
- Fixed in 16.1.1 (released Jun 17, 2026, 90 days before disclosure).
- The latest release, 16.1.4, is not affected.

### [CVE-2026-44202](https://cve.now/CVE-2026-44202): OpenAM Authenticated Server-Side Request Forgery (SSRF) via \`/sessionservice\`

- Severity: Medium 5.3
- Published: Sep 15, 2026
- Affected: fixed in 16.1.1.
- Fixed in 16.1.1 (released Jun 17, 2026, 90 days before disclosure).
- The latest release, 16.1.4, is not affected.

### [CVE-2026-62379](https://cve.now/CVE-2026-62379): OpenAM: Unauthenticated Remote Code Execution via Class.forName in AuthXMLUtils.createCustomCallback

- Severity: Critical 9.8
- Published: Sep 15, 2026
- Affected: fixed in 16.1.2.
- Fixed in 16.1.2 (released Jul 20, 2026, 57 days before disclosure).
- The latest release, 16.1.4, is not affected.

### [CVE-2026-53660](https://cve.now/CVE-2026-53660): OpenAM Insecure SSO Cookie Initialization

- Severity: High 7.4
- Published: Sep 15, 2026
- Affected: fixed in 16.1.1.
- Fixed in 16.1.1 (released Jun 17, 2026, 90 days before disclosure).
- The latest release, 16.1.4, is not affected.

### [CVE-2022-34298](https://cve.now/CVE-2022-34298): The NT auth module in OpenAM before 14.6.6 allows a "replace Samba username attack."

- Severity: Unrated
- Published: Jun 22, 2022
- Affected: fixed in 14.6.6.
- Fixed in 14.6.6 (released Jun 22, 2022, the day of disclosure).
- The latest release, 16.1.4, is not affected.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/maven/org.openidentityplatform.openam:openam-core
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
