Skip to main content
← Maven

org.jenkins-ci.plugins:mailer

5 known vulnerabilities (1 low), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
5 · 1 low
Registry
Maven Central

Advisories 5

  • A missing permission check in Jenkins Mailer Plugin 391.ve4a_38c1b_cf4b_ and earlier allows attackers with Overall/Read access to use the…

    Affected: from 391.ve4a38c1bcf4b, fixed in 408.vd726a; fixed in 1.34.2.

  • A cross-site request forgery (CSRF) vulnerability in Jenkins Mailer Plugin 391.ve4a_38c1b_cf4b_ and earlier allows attackers to use the…

    Affected: from 391.ve4a38c1bcf4b, fixed in 408.vd726a; fixed in 1.34.2.

  • Jenkins Mailer Plugin 1.32 and earlier does not perform hostname validation when connecting to the configured SMTP server.

    Affected: from 1.32, fixed in 1.32.1; from 1.30, fixed in 1.31.1; fixed in 1.29.1.

  • jenkins-mailer-plugin before version 1.20 is vulnerable to an information disclosure while using the feature to send emails to a…

    Affected: fixed in 1.20.

  • Cross-site request forgery (CSRF) vulnerability in the Mailer Plugin 1.20 for Jenkins 2.111 allows remote authenticated users to send…

    Affected: fixed in 1.21.