Skip to main content
← Maven

org.jenkins-ci.plugins:build-publisher

4 known vulnerabilities (1 high, 2 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 1 high, 2 medium
Registry
Maven Central

Advisories 4

  • A cross-site request forgery (CSRF) vulnerability in Jenkins Build-Publisher Plugin 1.22 and earlier allows attackers to replace any…

    Affected: through 1.22.

  • CVE-2022-41231Medium 5.7

    Jenkins Build-Publisher Plugin 1.22 and earlier allows attackers with Item/Configure permission to create or replace any config.xml file…

    Affected: through 1.22.

  • CVE-2022-41230Medium 4.3

    Jenkins Build-Publisher Plugin 1.22 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with…

    Affected: through 1.22.

  • Jenkins Build-Publisher plugin version 1.21 and earlier stores credentials to other Jenkins instances in the file…

    Affected: fixed in 1.22.