Skip to main content
← Maven

org.eclipse.jetty:jetty-servlets

4 known vulnerabilities (2 medium, 2 low), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 2 medium, 2 low
Registry
Maven Central

Advisories 4

  • Jetty PushSessionCacheFilter can cause remote DoS attacks

    Affected: from 10.0.0, through 10.0.17; from 11.0.0, through 11.0.17; from 12.0.0, through 12.0.3; from 10.0.0, fixed in 10.0.18; from 11.0.0, fixed in 11.0.18; from 12.0.0, fixed in 12.0.4.

  • CVE-2024-9823Medium 5.3

    Jetty DOS vulnerability on DosFilter

    Affected: from 9.0.0, fixed in 9.4.54; from 10.0.0, fixed in 10.0.18; from 11.0.0, fixed in 11.0.18; from 9.0.0, fixed in 9.4.54; from 10.0.0, fixed in 10.0.18; from 11.0.0, fixed in 11.0.18.

  • Jetty vulnerable to errant command quoting in CGI Servlet

    Affected: from 9.0.0, fixed in 9.4.52; from 10.0.0, fixed in 10.0.16; from 11.0.0, fixed in 11.0.16.

  • CVE-2021-28169Medium 5.3

    For Eclipse Jetty versions <= 9.4.40, <= 10.0.2, <= 11.0.2, it is possible for requests to the ConcatServlet with a doubly encoded path to…

    Affected: fixed in 9.4.41; from 10.0.0, fixed in 10.0.3; from 11.0.0, fixed in 11.0.3.