Skip to main content
← Maven

org.apache.solr:solr

4 known vulnerabilities (1 critical, 1 high), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 1 critical, 1 high
Registry
Maven Central

Advisories 4

  • Apache Solr: ConfigSets created during a backup restore command are trusted implicitly

    Affected: from 6.6.0, fixed in 8.11.4; from 9.0.0, fixed in 9.7.0.

  • CVE-2024-45216Critical 9.8

    Apache Solr: Authentication bypass possible using a fake URL Path ending

    Affected: from 5.3.0, fixed in 8.11.4; from 9.0.0, fixed in 9.7.0.

  • Cross-site scripting (XSS) vulnerability in webapp/web/js/scripts/schema-browser.js in the Admin UI in Apache Solr before 5.3 allows…

    Affected: fixed in 5.3.

  • Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to…

    Affected: from 4.0.0, fixed in 4.10.3.