Skip to main content
← Maven

org.apache.pulsar:pulsar

4 known vulnerabilities (1 critical, 1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 1 critical, 1 medium
Registry
Maven Central

Advisories 4

  • CVE-2023-30429Critical 9.6

    Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy

    Affected: fixed in 2.10.4; from 2.11.0, fixed in 2.11.1.

  • CVE-2022-24280Medium 6.5

    Apache Pulsar Proxy target broker address isn't validated

    Affected: fixed in 2.7.5; from 2.8.0, fixed in 2.8.3; from 2.9.0, fixed in 2.9.2.

  • Pulsar Admin API allows access to data from other tenants using getMessageById API

    Affected: through 2.6.4; from 2.7.0, fixed in 2.7.4; from 2.8.0, fixed in 2.8.1.

  • Authentication with JWT allows use of “none”-algorithm

    Affected: fixed in 2.7.2.