# org.apache.kylin:kylin-core-common (Maven) vulnerabilities

6 known vulnerabilities (1 critical, 5 high), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 5.0.5 (Oct 12, 2026): no advisory affects it
- Newest unaffected release: 5.0.5 (Oct 12, 2026), the latest release
- Dependents: 43
- Releases: 49 since 1.5.0 (Mar 12, 2016)
- Registry: https://central.sonatype.com/artifact/org.apache.kylin/kylin-core-common
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2025-61735: 4.0.0 to 5.0.2 (5.0.3 is outside it)
- CVE-2025-61733: 4.0.0 to 5.0.2 (5.0.3 is outside it)
- CVE-2025-61734: 4.0.0 to 5.0.2 (5.0.3 is outside it)
- CVE-2023-29055: 2.0.0 to 4.0.3 (4.0.4 is outside it)
- CVE-2022-24697: 1.5.0 to 4.0.1 (4.0.2 is outside it)
- CVE-2020-1956: 1.5.0 to 2.6.5 (2.6.6 is outside it); 3.0.0 to 3.0.1 (3.0.2 is outside it)

## Advisories (6)

### [CVE-2025-61735](https://cve.now/CVE-2025-61735): Apache Kylin: Server-Side Request Forgery

- Severity: High 7.3
- Published: Oct 2, 2025
- Affected: from 4.0.0, fixed in 5.0.3.
- Fixed in 5.0.3 (released Sep 18, 2025, 14 days before disclosure).
- The latest release, 5.0.5, is not affected.

### [CVE-2025-61733](https://cve.now/CVE-2025-61733): Apache Kylin: Authentication bypass

- Severity: High 7.5
- Published: Oct 2, 2025
- Affected: from 4.0.0, fixed in 5.0.3.
- Fixed in 5.0.3 (released Sep 18, 2025, 14 days before disclosure).
- The latest release, 5.0.5, is not affected.

### [CVE-2025-61734](https://cve.now/CVE-2025-61734): Apache Kylin: improper restriction of file read

- Severity: High 7.5
- Published: Oct 2, 2025
- Affected: from 4.0.0, fixed in 5.0.3.
- Fixed in 5.0.3 (released Sep 18, 2025, 14 days before disclosure).
- The latest release, 5.0.5, is not affected.

### [CVE-2023-29055](https://cve.now/CVE-2023-29055): Apache Kylin: Insufficiently protected credentials in config file

- Severity: High 7.5
- Published: Jan 29, 2024
- Affected: from 2.0.0, fixed in 4.0.4.
- Fixed in 4.0.4 (released Jan 20, 2024, 9 days before disclosure).
- The latest release, 5.0.5, is not affected.

### [CVE-2022-24697](https://cve.now/CVE-2022-24697): Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system parameters

- Severity: Critical 9.8
- Published: Oct 13, 2022
- Affected: fixed in 4.0.2.
- Fixed in 4.0.2 (released Aug 28, 2022, 46 days before disclosure).
- The latest release, 5.0.5, is not affected.

### [CVE-2020-1956](https://cve.now/CVE-2020-1956): Apache Kylin 2.3.0, and releases up to 2.6.5 and 3.0.1 has some restful apis which will concatenate os command with the user input string, a

- Severity: High 8.8 · KEV
- Published: May 22, 2020
- Affected: fixed in 2.6.6; from 3.0.0, fixed in 3.0.2.
- Fixed in 2.6.6 (released May 12, 2020, 10 days before disclosure) and 3.0.2 (released May 12, 2020, 10 days before disclosure).
- The latest release, 5.0.5, is not affected.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/maven/org.apache.kylin:kylin-core-common
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
