Skip to main content
← Maven

org.apache.jspwiki:jspwiki-main

18 known vulnerabilities (1 high, 3 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
18 · 1 high, 3 medium
Registry
Maven Central

Advisories 18

  • CVE-2025-24854Medium 6.1

    Apache JSPWiki: Cross-Site Scripting (XSS) in JSPWiki Image plugin

    Affected: fixed in 2.12.3.

  • Apache JSPWiki: Cross-Site Scripting (XSS) in JSPWiki Header Link processing

    Affected: fixed in 2.12.3.

  • CVE-2024-27136Medium 6.1

    Apache JSPWiki: Cross-site scripting vulnerability on upload page

    Affected: fixed in 2.12.2.

  • Apache JSPWiki: XSS Injection points in several plugins

    Affected: fixed in 2.12.0.

  • User Group Privilege Escalation

    Affected: fixed in 2.11.3.

  • Apache JSPWiki Cross-site scripting vulnerability on WeblogPlugin

    Affected: fixed in 2.11.3.

  • Apache JSPWiki CSRF in UserPreferences.jsp

    Affected: fixed in 2.11.3.

  • Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp

    Affected: fixed in 2.11.3.

  • XSS vulnerability on XHRHtml2Markup.jsp in JSPWiki 2.11.2

    Affected: fixed in 2.11.3.

  • Apache JSPWiki Cross-site scripting vulnerability on User Preferences screen

    Affected: fixed in 2.11.2.

  • Apache JSPWiki CSRF Account Takeover

    Affected: fixed in 2.11.2.

  • Arbitrary file deletion on logout

    Affected: fixed in 2.11.0.

  • XSS vulnerability on Denounce plugin

    Affected: fixed in 2.11.0.

  • On Apache JSPWiki, up to version 2.11.0.M4, a carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache…

    Affected: fixed in 2.11.0.M5.

  • A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to…

    Affected: from 2.9.0, fixed in 2.11.0.M4.

Show all 18 advisoriesShow fewer advisories
  • A carefully crafted InterWiki link could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to session…

    Affected: from 2.9.0, fixed in 2.11.0.M4.

  • A carefully crafted malicious attachment could trigger an XSS vulnerability on Apache JSPWiki 2.9.0 to 2.11.0.M3, which could lead to…

    Affected: from 2.9.0, fixed in 2.11.0.M4.

  • In Apache JSPWiki 2.9.0 to 2.11.0.M2, a carefully crafted URL could execute javascript on another user's session.

    Affected: from 2.9.0, fixed in 2.11.0.M3.