Skip to main content
← Maven

org.apache.ambari:ambari

8 known vulnerabilities (2 high, 1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
8 · 2 high, 1 medium
Registry
Maven Central

Advisories 8

  • CVE-2023-50378Medium 6.1

    Apache Ambari: Various XSS problems

    Affected: fixed in 2.7.8.

  • Apache Ambari: Allows authenticated metrics consumers to perform RCE

    Affected: from 2.7.0, fixed in 2.7.7.

  • Apache Ambari: A malicious authenticated user can remotely execute arbitrary code in the context of the application.

    Affected: from 2.7.0, fixed in 2.7.7.

  • Stored XSS in Apache Ambari

    Affected: fixed in 2.7.4.

  • Apache Ambari 2.x before 2.4.0 includes KDC administrator passwords on the kadmin command line, which allows local users to obtain…

    Affected: from 2.0.0, fixed in 2.4.0.

  • Custom commands may be executed on Ambari Agent (2.4.x, before 2.4.2) hosts without authorization, leading to unauthorized access to…

    Affected: from 2.4.0, fixed in 2.4.2.

  • Open redirect vulnerability in Apache Ambari before 2.1.2 allows remote attackers to redirect users to arbitrary web sites and conduct…

    Affected: from 1.7.0, fixed in 2.1.2.

  • Server-side request forgery (SSRF) vulnerability in the proxy endpoint (api/v1/proxy) in Apache Ambari before 2.1.0 allows remote…

    Affected: from 1.5.0, fixed in 2.1.0.